ข่าว Ethereum

 พบข้อผิดพลาดร้ายแรงบน Ethereum ทำให้เกิดการ double spending

ข้อผิดพลาดถูกพบในการออดิทบน Telos EVM เป็น Ethereum EVM ที่ทำงานบนบล็อกเชน  Telos โดย Guido Vranken นักพัฒนา จาก Sentnl โดยเขากล่าวว่าเป็นข้อมผิดพลาดร้ายแรง

หลังจากที่นักพัฒนาหลักของ Ethereum ได้รับแจ้งแล้ว ก็ได้ปล่อยอัพเดทเพื่อแก้บักทันทีในวันที่ 24 สิงหาคม ที่ผ่านมา แต่ก็ช่วยได้แค่คนที่ยอมอัพเดทเท่านั้น

ข้อผิดพลาดอยู่ในโปรแกรม Geth clients ซึ่งใช้รันโหนดของ ETH เวอร์ชั่น 1.10.7 หรือก่อนหน้านี้. ทำให้โหนดเกือบ 54% มีช่องโหว่ระดับเครือข่ายอยู่
ทำให้เกิดความกังวลที่จะเกิดปัญหา double spending หรือการใช้งานซ้ำซ้อนได้
ข้อผิดพลาดนี้กระทบไปทุกเชนที่ฟอร์ค Ethreum มา มีการพบทรานแซคชั่นที่ใช้งานช่องโหว่นี้แล้วทั้งบน BSC และ Heco Chain แต่ยังไม่เจอบน Polygon

Martin Swende หัวหน้าด้านความปลอดภัยของมูลนิธิ Ethereum ได้ทวีตว่า มีการพบช่องโหว่ที่รุนแรงบนเครือข่าย ethereum และได้แก้ไขไปแล้วในโปรแรกม geth เวอร์ชัน 1.10.8 โชคยังดีที่ นักขุดส่วนใหญ่ได้อัพเดทโปรแกรมแล้ว และสายเชนที่ถูกต้องได้ยาวกว่าที่ผิดพลาดแล้ว

 Tim Beiko นักพัฒนาหลักของ Ethereum ได้กล่าว่า นักขุดรายใหญ่ อย่าง Flexpool, BTC.com และ Binance ยังรันโหนดเวอร์ชันเดิมอยู่ โดย Flexpool เป็นคนที่รายงานข้อผิดพลาดนี้

 

ที่มา Link

To Top